Help us improve Answers HQ! Take Survey No, Thanks

DXGI-DEVICE-ERROR-REMOVED (new)

by xDD_LMAOOO
Reply

Original Post

Re: DXGI-DEVICE-ERROR-REMOVED (new)

★★ Apprentice

Here is the latest event, occured roughly 5-10 mins before I crashed.

 

Spoiler
Log Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 3/27/2019 1:00:37 AM
Event ID: 10016
Task Category: None
Level: Error
Keywords: Classic
User: USER-PC\user
Computer: user-PC
Description:
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}
and APPID
{15C20B67-12E7-4BB6-92BB-7AFF07997402}
to the user user-PC\user SID (S-1-5-21-1951253227-104793871-492778414-1000) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
<EventID Qualifiers="0">10016</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreated SystemTime="2019-03-26T14:00:37.660814700Z" />
<EventRecordID>18304</EventRecordID>
<Correlation />
<Execution ProcessID="1360" ThreadID="10840" />
<Channel>System</Channel>
<Computer>user-PC</Computer>
<Security UserID="S-1-5-21-1951253227-104793871-492778414-1000" />
</System>
<EventData>
<Data Name="param1">application-specific</Data>
<Data Name="param2">Local</Data>
<Data Name="param3">Activation</Data>
<Data Name="param4">{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}</Data>
<Data Name="param5">{15C20B67-12E7-4BB6-92BB-7AFF07997402}</Data>
<Data Name="param6">user-PC</Data>
<Data Name="param7">user</Data>
<Data Name="param8">S-1-5-21-1951253227-104793871-492778414-1000</Data>
<Data Name="param9">LocalHost (Using LRPC)</Data>
<Data Name="param10">Unavailable</Data>
<Data Name="param11">Unavailable</Data>
</EventData>
</Event>
Message 21 of 99 (280 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

Champion

DistrubutedCOM errors can be ignored.

 

Just as a thing to check hardware wise.

Reseat your GPU and check the power cables are connected.

 

Once the system clean has been done and the GPU reseat is done we may have to check power saving settings in two area's after.

Message 22 of 99 (289 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

[ Edited ]
★★ Apprentice

K well i've reseated the GPU and used the cleaning methods in your 3rd link. Played training for 10 mins, no crashes whatsoever. By now there should have already been one! Standard smile

 

Gonna mark that post of yours as the solution. If anything happens in the near future i'll update this thread. I'll be damned if the GPU wasn't fitted properly this whole time.

 

Regardless, cheers for the help man. Helped me so much Standard smile)))

Message 23 of 99 (260 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

Champion

Np bro Thumbs up

Message 24 of 99 (250 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

[ Edited ]
★★ Apprentice

Yeah it just happened again on the second game i played today. DEVICE-ERROR-HUNG was the error this time, rather than device removed. :/

 

side note: i did notice some visible 'hitching' or 'stuttering' playing through this time.

Message 25 of 99 (221 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

★★ Apprentice

Here is the display warning form event viewer

 

Spoiler
Log Name: System
Source: Display
Date: 3/27/2019 5:15:26 PM
Event ID: 4109
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
Computer: user-PC
Description:
Application r5apex.exe has been blocked from accessing Graphics hardware.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Display" />
<EventID Qualifiers="0">4109</EventID>
<Level>3</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2019-03-27T06:15:26.467909900Z" />
<EventRecordID>18436</EventRecordID>
<Channel>System</Channel>
<Computer>user-PC</Computer>
<Security />
</System>
<EventData>
<Data>r5apex.exe</Data>
<Data>
</Data>
</EventData>
</Event>

Also this followed shortly after as an error, but i do remember you telling me to ignore these. but here it is anyway.

 

Spoiler
Log Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 3/27/2019 5:15:34 PM
Event ID: 10016
Task Category: None
Level: Error
Keywords: Classic
User: USER-PC\user
Computer: user-PC
Description:
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}
and APPID
{15C20B67-12E7-4BB6-92BB-7AFF07997402}
to the user user-PC\user SID (S-1-5-21-1951253227-104793871-492778414-1000) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
<EventID Qualifiers="0">10016</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreated SystemTime="2019-03-27T06:15:34.027961300Z" />
<EventRecordID>18438</EventRecordID>
<Correlation />
<Execution ProcessID="1380" ThreadID="5556" />
<Channel>System</Channel>
<Computer>user-PC</Computer>
<Security UserID="S-1-5-21-1951253227-104793871-492778414-1000" />
</System>
<EventData>
<Data Name="param1">application-specific</Data>
<Data Name="param2">Local</Data>
<Data Name="param3">Activation</Data>
<Data Name="param4">{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}</Data>
<Data Name="param5">{15C20B67-12E7-4BB6-92BB-7AFF07997402}</Data>
<Data Name="param6">user-PC</Data>
<Data Name="param7">user</Data>
<Data Name="param8">S-1-5-21-1951253227-104793871-492778414-1000</Data>
<Data Name="param9">LocalHost (Using LRPC)</Data>
<Data Name="param10">Unavailable</Data>
<Data Name="param11">Unavailable</Data>
</EventData>
</Event>
Message 26 of 99 (220 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

Champion

Alright,

1. In my guide follow section 4 and whitelist Apex with both public and private boxes ticked:

https://answers.ea.com/t5/The-Barracks/Building-a-stable-foundation-for-your-PC-Windows/td-p/7605212

If you have a thirdparty antivirus (not windows defender) could you uninstall that please?

(if you do let me know which AV it is)

 

2. Press the win key and type power,

>click power and sleep settings.

>Click Additional power settings.

>Select the high performance plan:

>Then click change plan settings.

>Change advanced power settings.

Now here you can take you time to change power settings how you see fit but the key thing to change here is this bit:

set it to that and apply.

 

3.Right click your desktop and open Nvidia control panel.

> manage 3D settings.

>Program settings.

> Select Apex legends in the drop box.

> Set Power management to maximum performance.

> apply and close the window.

 

4. Right click your Win menu icon and select device manager.

Under System devices right click all the PCI-toPCI Bridge devices and update them.

(you will notice your system trying to adjust itself as you do this)

 

Also thanks for being patient, a new bug is hard to find a fix for especially users who wont spend time to identify the issue. :P

 

Message 27 of 99 (190 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

[ Edited ]
★★ Apprentice

The first 3 steps I already had done. Followed through with the 4th in device manager to see that they're already up to date.

 

(edit: no 3rd party anti-virus btw) 

Message 28 of 99 (183 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

Champion

Okay run CMD in admin and run each of these:

sfc /scannow
DISM.exe /Online /Cleanup-image /Scanhealth
DISM.exe /Online /Cleanup-image /Restorehealth

 

Im not sure if i mentioned this but uninstall Intel Rapid Storage Technology if you have it installed.

 

 

Message 29 of 99 (165 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

[ Edited ]
★★ Apprentice

Just tried those methods then, still crashed, and no I dont have rapid storage installed.

 

same error DXGI-DEVICE-ERROR-REMOVED

 

(edit: the crashes seem completely sporadic, the one yesterday was at the end of a match. The one I got just then was as I just reached the title screen.)

Message 30 of 99 (151 Views)

fifa-19-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help