Help us improve Answers HQ! Take Survey No, Thanks

DXGI-DEVICE-ERROR-REMOVED (new)

by xDD_LMAOOO
Reply

Original Post

Re: DXGI-DEVICE-ERROR-REMOVED (new)

★★ Apprentice

Followed the instructions above, so far 3 games no crashes will update l8r after more

Message 11 of 99 (274 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

[ Edited ]
★★ Apprentice

Ok well I have no clue what happened, game inst crashing anymore (at least for now, a restart might fix that but no issues whatsoever tonight

 

few things:

- I uninstalled and reinstalled APEX Legends through Origin

- my motherboard bios firmware was already up to date (didn't need updating or anything)

- I uninstalled my GPU drivers with DDU 3rd party software (clean and restart option)

- Installed Geforce 419.35 driver after restart

- No crashes at all.

 

Honestly didn't think this would work as I have done all of the steps above previously but without any success. It's quite possible that reinstalling my game while this new crash fix update got pushed out fixed my problem i guess? Must have been a corrupted file i guess? seriously tried the solution above many times + other 'solutions"

 

Regardless the issue inst present at least for now. I will probably update this post once more tomorrow just to see if a restart reverts anything.

 

(edit: added dxdiag of the game working normally if this means anything)

Message 12 of 99 (249 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

Champion

That's great news!

 

The Dxdiag is to show the infromation on your PC its not much to do with what issues you are experiencing.

 

Message 13 of 99 (245 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

[ Edited ]
★★ Apprentice

Yeah its as i thought, DXGI_ERROR_DEVICE_REMOVED is back at it again. Couldn't finish a single game again Frown

 

Guess i just have to wait for a fix then.

 

(for the record this was after i restarted my computer, no apexcrash.txt was generated either)

Message 14 of 99 (228 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

[ Edited ]
Champion

Thats wierd,

 

Could you post some event viewer logs for me?

https://answers.ea.com/t5/Technical-Issues/No-error-code-Read-here-for-extended-diagnositics-support...

 

This should be a consistent fix, something is changing Thinking

Make sure you are using the latest GPU driver BTW (a recent update happened)

https://www.nvidia.com/Download/driverResults.aspx/145534/en-us

 

Try a system cleanup with this guide and skip to the cleaning.

https://answers.ea.com/t5/The-Barracks/Building-a-stable-foundation-for-your-PC-Windows/td-p/7605212

 

Something else to try:

Spoiler
  1. Open an elevated command prompt. To do this, right click the Windows button, and then select Command Prompt (Admin). If you are prompted for an administrator password or for a confirmation, type the password, or click Allow or Yes.
  2. Type the following command, and then press Enter.
DISM.exe /Online /Cleanup-image /Restorehealth

Note It might take several minutes for the command operation to be completed.

  1. Type the following command and press Enter.
sfc /scannow

Note It might take several minutes for the command operation to be completed.

  1. Close the command prompt, and then run Windows Update
Message 15 of 99 (202 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

★★ Apprentice

I'l have to get to steps 2 and 3 tomorrow, however i've looked at the event viewer logs.

 

Im fairly certain of the time of the crash, and two events pop up around that time. One is a 'warning' for r5apex.exe being blocked from accessing the graphics hardware. The other is an error that was generated like 11 seconds after the display warning. Posting both below, 'warning' then 'error'. 

 

Spoiler
Log Name: System
Source: Display
Date: 3/26/2019 2:32:02 PM
Event ID: 4109
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
Computer: user-PC
Description:
Application r5apex.exe has been blocked from accessing Graphics hardware.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Display" />
<EventID Qualifiers="0">4109</EventID>
<Level>3</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2019-03-26T03:32:02.943137200Z" />
<EventRecordID>18259</EventRecordID>
<Channel>System</Channel>
<Computer>user-PC</Computer>
<Security />
</System>
<EventData>
<Data>r5apex.exe</Data>
<Data>
</Data>
</EventData>
</Event>
Spoiler
Log Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 3/26/2019 2:32:11 PM
Event ID: 10016
Task Category: None
Level: Error
Keywords: Classic
User: USER-PC\user
Computer: user-PC
Description:
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}
and APPID
{15C20B67-12E7-4BB6-92BB-7AFF07997402}
to the user user-PC\user SID (S-1-5-21-1951253227-104793871-492778414-1000) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
<EventID Qualifiers="0">10016</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreated SystemTime="2019-03-26T03:32:11.096566000Z" />
<EventRecordID>18261</EventRecordID>
<Correlation />
<Execution ProcessID="1360" ThreadID="12792" />
<Channel>System</Channel>
<Computer>user-PC</Computer>
<Security UserID="S-1-5-21-1951253227-104793871-492778414-1000" />
</System>
<EventData>
<Data Name="param1">application-specific</Data>
<Data Name="param2">Local</Data>
<Data Name="param3">Activation</Data>
<Data Name="param4">{2593F8B9-4EAF-457C-B68A-50F6B8EA6B54}</Data>
<Data Name="param5">{15C20B67-12E7-4BB6-92BB-7AFF07997402}</Data>
<Data Name="param6">user-PC</Data>
<Data Name="param7">user</Data>
<Data Name="param8">S-1-5-21-1951253227-104793871-492778414-1000</Data>
<Data Name="param9">LocalHost (Using LRPC)</Data>
<Data Name="param10">Unavailable</Data>
<Data Name="param11">Unavailable</Data>
</EventData>
</Event>

Thanks.

Message 16 of 99 (189 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

Champion

Hmm,

 

in programs and features unistall Intel Rapid Storage Technology if you have it.

Also what Antivirus are you using?

Message 17 of 99 (187 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

★★ Apprentice

Pretty sure its just windows defender, nothing 3rd party

Message 18 of 99 (185 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

Champion

Cool ill wait for you to finish the rest of the solutions and get back to me once your ready.

 

Thumbs up

Message 19 of 99 (182 Views)

Re: DXGI-DEVICE-ERROR-REMOVED (new)

★★ Apprentice

Just tried the new driver released today with fresh install. Ran around in training mode for about 5 mins before getting same error. Ill post the event logs here in a sec.

Message 20 of 99 (170 Views)

fifa-19-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help