Help us improve Answers HQ! Take Survey No, Thanks

Cant even select my first Javelin to start playing this game.

by Darkhael

Original Post

Cant even select my first Javelin to start playing this game.

★★★★ Novice

Product: Anthem
Please specify your platform model. PC
AMD or Nvidia Model Number Nvidia Geforce GTX 1080
Enter RAM memory size in GB 16 GB
Please select your region Europe
Were you on an Expedition when the issue occurred? No
Where did this issue occur? Please include menu name or in game location. Getting to know the Forge quest right after tutorial mission.
When did this happen? ( hh:mm) 27.02.2019
Summarize your bug I can't unlock my first Javelin. When I first accessed the Forge I managed to see the selection screen for Javelins. I selected Colossus and for some reason the loading animation stopped in around 90 % completion. Game became unresponsive and I had to close it. After this I tried to access the Forge again and it showed just double loading screens and returned me back to Fort Tarsis. I have now tried again in 1.0.4 patch and now Forge can be opened but it doesn't show any Javelin and gets stuck if I press the Space.
How often does the bug occur? Every time (100%)
Steps: How can we find the bug ourselves? Fail to select the first Javelin and then try to open the Forge.
What happens when the bug occurs? Forge screen doesn't show any Javelins and I can't progress with the game at all
What should be happening instead? I should have the Javelin selection again or Colossus selected as I intended to pick it

I'm writing this as a new bug report since I was requested to do so by the EA support team. There are multiple issues like this already.

Message 1 of 1 (36 Views)
Twitter Stream