Help us improve Answers HQ! Take Survey No, Thanks

Re: Bug within loading screen

by EA_Darko

Original Post

Bug within loading screen

★★ Newbie

Product: Apex Legends
Please specify your platform model. PC
AMD or Nvidia Model Number GEFORCE GTX
Enter RAM memory size in GB 16 GB
What is your gamertag/PSN ID/EA Account name? ChowChowT
Please provide your squad mates' gamertag/PSN ID/EA Account name if possible.
Which Legend were you playing (if applicable)?
Which Legends were your squad mates using (if applicable)?
Where did the issue occur? Loading into the match from the lobby
Which part of the map or menu were you in? If you don't remember the exact name, please describe the area or what you were trying to do in the menu. Loading Screen
What were you doing when the issue occurred? E.g. respawning a squad mate at a beacon, using an ability, a squad mate left the game. Loading Screen
Did your squad mates also experience the issue? Yes
How many matches had you played in a row before the issue occurred? 0
When did this happen? ( hh:mm) 30.06.19
How often does the bug occur? Every time (100%)
How severe is your issue? Major impacts to gameplay
What happens when the bug occurs? Party squad on the same network d/c every time squad leader starts.
What should be happening instead? Go into a match
Steps: How can we find the bug ourselves? Load on the same network and try to start a match

Is the only way to change the ip settings?
Can't apex legends follow similar tactics used in Fortnite, Call of Duty, CSGO, and other FPS games? I find it to be quite complicated for such a simple problem. Could there be a patch possible to eliminate such a bug in the upcoming future? Thank you and have a nice day!

Message 1 of 2 (57 Views)

Re: Bug within loading screen

Community Manager

Sorry to hear that you are having issues @chowchowt.


Can you check your Nat type is set to open, your friends will need to do the same. I would also suggest ensuring that you are all on the same internet protocol. For example, if you are on IPv4 and they are on IPv6 then you can have issues.


If it's still not fixed can you try:

  • Log into your modem / router
  • Turn OFF UPNP.Turn off PC UPnP Service:Press: Windows-button a window should pop up. Write: “services.msc” (without the “) then press enter
  • In the list of services, scroll down to “UPnP Device Host”, click it and press “Stop service”. Now do the same thing but with the service “SSDP Discovery”.Exit the window and go to control panel-> Network and Internet-> Network and Sharing Centre-> Change advanced sharing settings (to the left)-> Under “network discovery” select to turn off network discovery
  • Save your changes

Still not working after this? Can you go ahead and on your console manually set your DNS so that it uses the Google DNS settings. You need to set them to and


Let me know how you get on.


Message 2 of 2 (27 Views)


Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection


Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help