Help us improve Answers HQ! Take Survey No, Thanks

Re: [OPEN] Gallery showing wrong packs used

by Timoram
Reply

Original Post

Re: Unused packs showing in gallery builds

★★★ Guide

@Timoram Good job on doing this extensive testing! Just one side note. You don't have to be enrolled in a career to reproduce the astronaut outfit + random DLC shoes issue. When I play a new Sim, the first thing I tend to do is, to acquire the Nerd Brain Aspiration which requires my Sim to upgrade or ride on a rocket at a certain point. By doing the latter, the Sim often returns home with a random DLC shoe attached to his astronaut outfit. Earlier (like back in the 2014's) it wasn't much of an issue since there were very few DLCs to pick from, but with the number of DLCs we have today, you can almost be certain that some of them gets picked by the game. So, simply riding on a rocket may be the easiest way to do some testing.

Message 61 of 71 (497 Views)

Re: Households saved to your library not properly tagged with packs used

★★★★ Novice

The random hidden clothing happens with mannequins too.

I discovered that mannequins, when you go live mode and dress them, load random haistyles even if they don't have hair. I built a showroom with limited packs, I wanted to upload the build with the mannequins all dressed up so had to do it from live mode. I was extracareful not to dress them with packs I didn't use in the build AND to use sims solely dressed with base game but suddenly the build was showing packs I didn't put into it. The gallery showed me hairstyles. It was the mannequins and I had no way to change their hairs so I just uploaded and warned in the description of this bug.

Message 62 of 71 (482 Views)

Re: Unused packs showing in gallery builds

★★ Pro
@Timoram Great job with all the testing!

Another problem is the Digital Deluxe DLC. Digital Deluxe doesn’t have a tag in CAS or BB. If you upload a household or build with Digital Deluxe items the gallery will not show any used packs, but if someone without Digital Deluxe downloads the household or build they will get the “items removed” message. Digital Deluxe costs around 15 dollars, but it’s not treated as a pack by the game. This is why Kayla Flemming and Baby Ariel (from Get Famous) don’t have any formal outfit, and Mark Eggleston (from StrangerVille) doesn’t have a party outfit, they’re in their underwear for those clothing categories, for people who don’t own Digital Deluxe. So, official pre-mades are wearing clothes from a paid DLC.

Yet another thing is that pack-specific aspirations and traits aren’t tagged in the gallery. The official version of Hina Matsumoto, from the Snowy Escape trailer, has a trait from Island Living.
Message 63 of 71 (470 Views)

Re: Unused packs showing in gallery builds

★★★ Apprentice

@Japanic2012 Thanks! I have edited my long post to make note of your observations.

 

@Katrus91 I think Jules Rico (pre-made Sim in Port Promise from Eco Lifestyle's) also has the same issue here. His facial hair is apparently from the Parenthood game pack, and if you attempt to export his household to his gallery, Parenthood will be (logically) flagged even with no change to Sims in Jules' household. It can thus be counter-intuitive why Parenthood gets flagged since pre-made Sims in previous packs usually include exclusively CAS items from the pack they are included in. (Except the ones you mentioned which have Digital Deluxe items thrown in…)

Message 64 of 71 (404 Views)

Re: [OPEN] Gallery showing wrong packs used

★★★★★ Newbie

This has also happens to me, arounf 70-80% of the time, it's incredibly frustrating. I'm building with only basegame, but the gallery doesn't seem to acknowledge that... I'm running the latest version of sims (1.72.28.1030) on PC, and I have all packs, stuff packs and game packs (but used none of these items). By and by, when in build and buy mode, the 'basegame only' filter will constantly turn itself off, but I've gotten into the habit of checking it before I place absolutely anything now, and it still registers packs where there are none. I'm extremely careful when checking through the house before uploading it to the gallery. Hope they fix this soon, it's really ruining my project to reinvent a basegame world.

Message 65 of 71 (331 Views)
0

Re: [OPEN] Gallery showing wrong packs used

Hero

Fixed an issue in which in the Gallery Preview pop ups, Build Mode objects will now appear properly under the “Show Used Items” panel. Accuracy is the best policy… in this case.

Another partial fix for this

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


Message 66 of 71 (217 Views)
0

Re: [OPEN] Gallery showing wrong packs used

[ Edited ]
★★★ Apprentice

I'm elated to see that they manage to mostly fix and test that one this quickly! One annoying sub-bug out of the way

 

It's still a partial fix, though. After testing, the following Build object types still don't show up in the Gallery Preview pop ups (both under the "Show Used Items" and under the general list):

  • Pool water styles (added with Get Together and Jungle Adventure, will flag their DLC anyway when saving a lot or room)
  • Fountain trims (which as of today matters to the only DLC fountain trim there is, which was added with Spa Day but does not flag its DLC when saving a lot or room)

Additionally, that terrain paints are also in the Gallery Preview pop ups, you can add them to the list of items affected by the last bug I've tested:

 

  • Some individual Build mode objects will not show up in the list of used items in the Gallery Preview pop ups. For DLCs that comes with terrain paints, some paints appear in the Gallery Preview pop ups, some do not; some flag their DLC, some do not.
    • Tested with Eco Lifestyle, Island Living and Outdoor Retreat; could affect more DLCs
    • How to reproduce:
      1. Go into Build Mode on an empty lot with no household
      2. Bulldoze the lot to remove any object or existing terrain paint
      3. Use on the ground a single terrain paint which comes from a given DLC (Eco Lifestyle for instance)
      4. Save the lot to the Gallery
      5. In the Gallery, verify if the DLC you used the terrain paint from is flagged or not
      6. If yes, in the Gallery Preview pop up for this DLC, under the "Show Used Items" panel, verify if the terrain paint you used appears or not. If not, continue to step 7
      7. Repeat steps 2–6 for every terrain paint in this DLC to reproduce this bug. (If you started with Eco Lifestyle in step 3, one of the two terrain paints will not flag it in step 5, else will not show up in step 6.)
      8. When in doubt, compare with the list of Build mode objects included in a DLC in its Gallery Preview pop up: there should be less terrain paints included than there actually is in Build mode.

Minor, unrelated bug: platform trims are shown in the Gallery Preview pop ups with square blank icons with a red cross. Perhaps thumbnail images for platform trims are needed here?

 

(To the devs and QA people out there: you're almost there with this one, don't give up!)


 

EDIT: I'd like also to amend one sub-bug I've preciously reported on page 6:

  • Unlockable CAS items or craftable Build items don't consistently flag their packs in the Gallery. Several types of crafted objects or individual crafted objects created in Live Mode and left on lots or rooms exported to the Gallery may or may not flag their DLC of origin, but do not appear in the list of used items in the Gallery Preview pop ups. We've noticed so far:
    • Food items that were fully cooked/baked with an oven or a microwave often flag their DLC or origin. (If their preparation was interrupted for any reason, they don't seem to flag their DLC on their own)
      • Kebab Pizza does not flag Discovery University. Perhaps other pizza toppings from this DLC do not flag it either...
    • Fully prepared ice creams do not flag Cool Kitchen Stuff
    • Popcorn bowls prepared with the popcorn machine do not flag Movie Hangout Stuff.
    • Individual kawa drinks do not flag Island Living
    • Gourmet pet food do not flag Cats & Dogs
    • Individual drinks from drink trays flag neither Spa Day nor Backyard Stuff
    • Knitted objects do not seem to flag Nifty Knitting Stuff
    • Chalk Séance circles do not flag Paranormal Stuff
    • Flower arrangements do not flag Seasons
    • Lotions do not flag Outdoor Retreat
    • Cauldron potions do not flag Realm of Magic

This is all I could test so far, and it appears to be mostly food related. I'd also like take back what I've written about plants, we haven't been able to double-check them again and thus can't confirm if they flag their DLC of origin :-(

It's not much, but I hope that this breadcrumbs will help in investigating the root cause(s) of this sub-bug!

Message 67 of 71 (180 Views)

Re: [OPEN] Gallery showing wrong packs used

Hero
@Timoram Would you mind making a new thread for each of those ?

At this point it's best if we have separate threads actually (they have fixed two sub-issues so far)

Think 3 bug reports for each of your sections would be best.
- Build objects types (list them as you did here)
- Individual objects (also with a list)
- Unlockables/craftable.

Happy Gaming
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Please only contact me via PM when asked to do so.



Important Threads


Message 68 of 71 (158 Views)
0

Re: [OPEN] Gallery showing wrong packs used

★★★ Apprentice
@crinrict Of course! I'll try to do that. Thank you for the suggestions!
Message 69 of 71 (127 Views)

Re: [OPEN] Gallery showing wrong packs used

★★★ Apprentice

As requested, here are links to each of these bugs. After some more testing, I took the liberty of splitting the last ("Unlockable/craftable") in two separate bugs since they were quite different in how to reproduce them.

 

The platform trim-related bug also has its own thread now:

Phew, that was a lot of writing!

Message 70 of 71 (529 Views)