BF4 black loading screen

by MightGoDownAsGOD
Reply

Original Post

BF4 black loading screen

[ Edited ]
★★ Novice

Hello,

 

When I joining to the server I got in game black screen. In battlelog that blue table shows "Loading level", but in game black screen. It's so annoying.

Message 1 of 2 (207 Views)

Re: BF4 black loading screen

Hero (Retired)

@MightGoDownAsGOD Make sure all this is up to date and do this for settings please....  

 

Latest version of DirectX see this page
http://www.microsoft.com/en-ca/download/confirmation.aspx?id=35

Reinstall Microsoft C++ ...I install both on my PC's your call how you want to do it
NOTE>>> you need to select the x64 or the x86 file depending on what architecture your computer has. To find this out, Click Start, right click on "Computer" and select "Properties". Under system type is should say "32-Bit Operating System" or "64-bit Operating System". If 32-bit operating system, download the x86 file, and if 64-bit download the x64 file.
http://www.microsoft.com/en-US/download/details.aspx?id=40784

Update your Microsoft .NET framework.
http://www.microsoft.com/en-ca/download/details.aspx?id=30653

Adobe Flash Player update
http://get.adobe.com/flashplayer/

Reboot PC 

 

Run the game as Administrator:
Go to the Origin games folder (C:\Program Files (x64)\Origin Games\Battlefield 4) and find Bf4.exe. Right click it and go to PROPERTIES, then COMPATIBILITY and check the box next to RUN THIS PROGRAM AS ADMINISTRATOR.
Do the same with BF4_x86.exe as well.

Run Origin as Administrator:
Go to C:\Program Files (x86)\Origin and right click on Origin.exe and go to properties. Then go to compatibility tab and check the box next to RUN AS ADMIN.

Disable Origin in game:
In Origin - Application settings - Origin in Game - disable Origin in game

Origin Cloud Storage turn it off
Origin, settings, General

Make Sure BF4 is set to 64bit if your windows is 64bit
1- open origin and go to My Games
2-Right click BF4 and go to Game Properties
3-Under when launching this game set it to x64 and check off disable origin in game.
4- Hit apply REBOOT your PC and then test your BF4

Reboot PC test BF4

If you still crash see information below....

Try a clean boot : run a Clean Boot: http://help.ea.com/en/article/how-to-clean-boot-your-pc/
This should ensure that no programs are interfering in the background.

Below are programs known to make issues in BF4

Disable Mantle if you have it and try Direct X, Turn OFF Anti-Aliasing Deferred in video card settings in game. If you have page file turned off then turn it back on as this can make errors even with 32gigs ram.

Others have said if they uninstall MSI Afterburner issues / crashing is stopped. So if you have this installed remove program and test BF4. Also look at other programs as Asus Game First Service...ROG Game First , Razer synapse, Razer Cortex, Qualcomm Killer Service , Fraps, EVGA Precision, Geforce experience, be sure to turn off the streaming function that is enabled by default ,Raptr, RivaTuner , ASRock eXtreme Tuner, Steam, Skype, aero ,Overwolf extra program in teamspeak and xfire are known to make issues as well. And I am sure more programs not in my list yet turn one off at a time and test BF4.

Uninstall the HD Audio Driver from the video card driver install add/remove programs. This silly thing makes issues in BF4 for some. Reboot then repair BF4 to be safe.


If all this fails to fix it then try this...

C:\Users\your PC Name\Documents\Battlefield 4

BF4 folder in my documents holds game configs and screen shots even if BF4 is installed on different drive. When you uninstall BF4 it does NOT remove this folder. So when you install the game again you can still have the same issues. Even if its not a new install it is still worth trying as the game cfg could be mucked up.

1- Go to my Documents and remove BF4 folder place it on your Desktop for now.
2- Be warned you do have to set up your in game settings again.
3-Repair BF4
4- When done go test your game. If it fails reboot your PC and run repair game again and test BF4.

Message 2 of 2 (188 Views)