Help us improve Answers HQ! Take Survey No, Thanks

Catalyst fails to start due to MOM.Implementation error with .NET Framework

by Marvit0
Reply

Original Post

Highlighted

Catalyst fails to start due to MOM.Implementation error with .NET Framework

[ Edited ]
★★★★ Novice

Hi all,

 

Windows did an updated to .NET framework 4 and after I restarted my computer everything looked fine at first. HDMI sound and screen resulotion were OK. A few seconds after my account logged in an error message appeared saying:

"Could not load file or assembly 'MOM.implementation' or one of its dependencies. The system cannot find the file specified"

 

The main issue now is that AMD Catalyst Control Center is not showing up. The drivers are installed correctly but CCC denies to start. 
I tried to :

Clean uninstalled catalyst.

Delete : HKCU/Software/ATI/ACE

Delete : HKLM/Software/ATI/ACE

Detele local and temp ATI folders.

Clean uninstalled .Net framework 4
Reinstalled .Net framework 4
Updated windows 
(No CCC, MOM, ACE windows\assembly entry found)
Reinstalled catalyst

But the problem was not solved. I tried installing .NET framework in different orders, older to newer and then install CCC but that did not work. Older versions of CCC has also been tested with no luck.

This thread has been tested with no luck either:
http://support.amd.com/us/kbarticles/Pages/26494-Radeon-MOM-CCC-implementation.aspx

So I had to re-install Windows 7 64bit.
Updated my system to SP1.
Installed .Net framework 4.5
Installed Catalyst, skype, VLC, winrar, google Chrome, cpuz and HWmonitor stand alone exe files.
Made a restor point and restarted my PC.
 
Catalyst working fine and everything untilI installed Origin and Battlefield 3. Something during the installing or updates to DirectX or C++ is messing my Catalyst Control Center which is resulting is me not being able to start any games.
My perfectly working hardware is rendered useless due to a software update/issue. 
And I feel helpless facing a problem for several days as if I was a computer engineer while I am just a humble customer.
 
Can you please help and thank you all in advance. 
 
System specs:
CPU: Intel i7-870
Motherboard: Gigabyte LGA1156 P55-UD3 
Graphic card: AMD Radeon HD6870 1GB
RAM: Corsair XMS3 8GB DDR3 
OS: Windows 7 64bit

 

Message 1 of 1 (1,577 Views)

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help