Help us improve Answers HQ! Take Survey No, Thanks

Re: My Logitech Rumblepad2 doesnt work in-game

by EA_Cade
Reply

Original Post

My Logitech Rumblepad2 doesnt work in-game

★ Novice

Now, I've tried all the methods I could try to fix this issue. I tried the xbox360 emulator, I tried disconnecting all non-essential USB devices, I even tried doing all this on 2 computers. Can someone please help me. And before you say, I tried it without Origin in-game.

Message 1 of 2 (681 Views)
Highlighted

Re: My Logitech Rumblepad2 doesnt work in-game

[ Edited ]
Community Manager

@JJGaming120 Hello! Sadly we can't offer support for third party peripherals here - I would recommend reaching out to Logitech on this.

-EA_Cade
Message 2 of 2 (633 Views)
Twitter Stream

fifa-20-promo-splash

Having trouble connecting to your game?

Try these steps first to clear up any problems you may have when connecting to an EA game.

Troubleshoot and test your connection

ea-help-promo

Forget your EA Account ID or password?

Reset, update, or link your account information.

View More on EA Help