Help us improve Answers HQ! Take Survey No, Thanks

The Sims 3 change language

by emilystrange8703
Reply

ORIGINAL POST

The Sims 3 change language

★★★★ Newbie
 I bought The Sims 3 on steam and installed it in Spanish since I'm from Mexico, played for a few days and everything was fine. Today I launch The game and tells me that there's a new patch, proceed to install it and after that, The language of The game changed to English! Now I can't play with The previous saved game that I had. How can I change The language back to Spanish?

 

Message 1 of 9 (13,543 Views)
Reply
0

Re: The Sims 3 change language

Hero

They had this issue with the asian version in 1.47. Steam has their own patches that are offered through Steam. Did you check the Steam forum if other people have the same issue ?

 

---

 

What is your base game version right now ?

To find out, open your launcher and hover over the little base game icon in the lower left part of the launcher. It should say 1.48.

More Details can be found here: http://sims3.crinrict.com/en/2011/01/tutorial-how-to-find-your-game-version.html

For Macs: http://bluebellflora.com/ts3-on-a-mac/checking-which-patch-version-youre-running

Good Luck and Happy Simmin
Crin

Trennlinie

I don't work or have any association with EA. I give advice to the best of my knowledge and cannot be held responsible for any damage done to your computer/game.
Questions belong in the forums. I don't answer questions via PM.
Help us helpers to help you

Thinking of helping out ? Please check the Helper's Corner for Sims 4 or Sims 3 and The Acadamy


Bitte akzeptiere eine Lösung, wenn dein Problem gelöst ist und verteile XP an Beiträge, die du hilfreich findest.
Ich arbeite nicht für EA und habe sonst auch keinerlei Verbindung zu EA.
PNs werden nicht beantwortet. Probleme gehören ins Forum

Message 2 of 9 (13,540 Views)
Reply
0

Re: The Sims 3 change language

★★★★ Newbie

1.48 is the version of my game and yes, it seems that Steam screwed up with this new patch. Thanks anyway!

Message 3 of 9 (13,532 Views)
Reply
0

Re: The Sims 3 change language

Champion

You need to change a registry value. Open a cmd window. And run regedit. Find

 

(32 bit)

HKEY_LOCAL_MACHINE\SOFTWARE

Sims

 

(64 bit)

HKEY_LOCAL_MACHINE\SOFTWARE

Wow6432node

Sims

 

In the right panel there is Locale

 

double click Locale

 

change the Value data from en-US to es-ES

 

click ok

exit regedit

 

you may need to do this for all packs

 

--------------------------------------------------------------------------------

Sign by Danasoft - For Backgrounds and Layouts

Message 4 of 9 (13,530 Views)
Reply
0

Re: The Sims 3 change language

★★★★ Newbie

I already did this several times but when y launch the game it is still in English and my saved game doesn't appear. Don't know what I'm doing wrong here. Frown

Message 5 of 9 (13,524 Views)
Reply
0

Re: The Sims 3 change language

[ Edited ]
Champion

hmmm...   Did you click ok after you changed the data? Try rebooting the computer as that key may only be read on boot . If the reboot doesn't work check to see if the key is actually set. If you are not the administrator you may have to run regedit with administartor rights.

 

--------------------------------------------------------------------------------

Sign by Danasoft - For Backgrounds and Layouts

Message 6 of 9 (13,522 Views)
Reply
0

Re: The Sims 3 change language

★★★★ Newbie

been searching for hours, your the first one to say to look under  the "Wow6432node" so thank you, thank you, thank you!

Message 7 of 9 (9,661 Views)
Reply
0

Re: The Sims 3 change language

★★★★ Newbie

LOVE YOU!!! Thank you so much!!!

Message 8 of 9 (4,118 Views)
Reply
0

Re: The Sims 3 change language

★★★★ Newbie
Thank you so much. You have save the day in my house. My ten yr old changed his settings and I could not figure it out, until I read your post. Thank you so much
Message 9 of 9 (685 Views)
Reply
0

Want more Sims?

Check out our Sims forums for tutorials and all things Sims.

View More