Help us improve Answers HQ! Take Survey No, Thanks

Sims 3 Install Shield won't work?

by snowballthebear
Reply

Original Post

Sims 3 Install Shield won't work?

[ Edited ]
★★★★ Novice

I have been trying to uninstall and reinstall the Sims 3 and Expansion packs because I recently had an issue with the game. I manually uninstalled all the expansion packs and the Base game and then I tried to download them through Origin. All of my games are saved on there, so I figured I would download them from there.

 

However, every time I try to install the game, the Install Shield immediately freezes. It doesn't even open up. It just minimizes into my task bar and freezes. Every time I try to click on it, it won't open! And whenever I hover my mouse over it to see what it looks like, it just gives me a blank page.

 

Also, whenever I start the task manager, it says that install shield is running, so I just end the process. But then when I check Origin, it says that the base game was installed and ready to play even though it's not!

 

This is preventing me from installing any expansion packs because when I try to install them, it says The Sims 3 base game must be installed in order to install the expansions even though Origin tells me that the base game is ALREADY Installed!!!

 

I need help please.

 

P.S. I am on Windows 7 and I DO have a copy of all my games in the form of a disc. Except for WA, which was the only expansion that actually installed without prompting me to first install the Base Game. I downloaded WA from Amazon.

 

*EDIT* I tried playing the Sims 3 and WA and they somehow work! But  I still can't install the other expansion packs.

Message 1 of 1 (428 Views)

Want more Sims?

Check out our Sims forums for tutorials and all things Sims.

View more

Check out the new EA Help!

We want to make finding the help you need better, faster, and easier.

So, we’ve had some work done at help.ea.com