Help us improve Answer HQ! Take Survey No, Thanks
Ask. Answer. Be the Hero.
Showing results for 
Search instead for 
Do you mean 
Reply
Keeper
amazingzebra
Posts: 8
Registered: ‎11-20-2012

Can't download the Sims 3. How do I fix this?

[ Edited ]

 I uninstalled the Sims 3 manually off my computer because the uninstall button didn't want to start up. I had all expantions downloaded on a internal D:/ drive and just formatted the D:/ drive since the Sims 3 was the only thing on there.

 I go back to download it again from Origin and it says:

 

The setup has detected that version 1.42.130 of the Sims 3 is already

installed.

 

This setup installs an earlier version of The Sims 3 (1.0.631).

 

You will have to uninstall the previous version before installing this

version.

 

 

I have done a full entire sweep of my computer looking for all files related to Sims 3 in documents, program files, install shields, program datas, and completely deleted all files that came up under EA or Sims3 format. I restart my computer and try again and it says the same thing. So, frustrated, I try using my CD to download it. Even the CD says it cannot download.

 

Anyone mind helping?

 

 

crinrict
Posts: 47,061
Topics: 176
XP: 4,392
Solutions: 4,079
Registered: ‎07-18-2012

Re: Can't download the Sims 3. How do I fix this?

Are you on a PC or Mac ?

Did you also clean out the registry ?

 

https://help.ea.com/article/manually-uninstalling-the-sims-3

 

Did you also clean out the origin folder in programs ?

 



Good Luck and Happy Simming
Crin



Please accept a solution if your issue is solved. XP is also appreciated
I don't work or have any association with EA
Questions belong in the forums. I don't answer questions via PM.
Help us helpers to help you

Bitte akzeptiere eine Lösung, wenn dein Problem gelöst ist und verteile XP an Beiträge, die du hilfreich findest.
Ich arbeite nicht für EA und habe sonst auch keinerlei Verbindung zu EA.
Keeper
amazingzebra
Posts: 8
Registered: ‎11-20-2012

Re: Can't download the Sims 3. How do I fix this?

Thank you so much. Deleting the registry did work. :cattongue: