September 2015 - last edited April 2016
Issue
Player gets a message that says “Warning! Your other device didn’t save your Springfield” when trying to load their game
Solution
Step 1
Message: Your other device didn’t save your Springfield. Please sign in to that device before playing
Action: Click “Play Now”
Step 2
Message: Play anyway? Some progress made on your other device may be lost
Action: Click “Continue”
Causes
How to minimise potential data loss/game progress
Forcing the game to synch on EA’s servers can and should save any progress made in your game up to that point. To that end it is worth doing one of the following each time before exiting your game: Visit your Krustyland OR clicking on the Bart and Milhouse icon on the bottom right of the screen to visit your friends screen.