Ask. Answer. Be the Hero.
Posts: 2
Registered: ‎11-22-2013

[SOLVED] Error: Missing MSVCP110.dll Code: 0xC1 [SOLVED]

[ Edited ]

First let me say that I have the dll's in both system32 and sysWOW64 folders, after confirming that Visual Studio 2012 Redistributables (Both: x86 and x64) contain the correct .dll's.


I have uninstalled completely, and reinstalled Need for Speed Rivals.


Computer Specs:


I ran the and I am cleared for running the game.

Which are:

OS: Microsoft Windows 8 Professional Edition (build 9200), 64-bit


CPU: AMD A10-6800K APU with Radeon(tm) HD Graphics 4.1 GHz


GPU: GeForce GTX 650 GDDR5

   -Pixel Shader version 5.0 Vertex Shader version 5.0 Dedicated Video RAM 2.0 GB


RAM: 12 GB (8GB DDR3 1866, 4GB DDR3 1866)


If there are any other details, please let me know.


Lastly, I do have DirectX Installed I can play other games with no problems that I am sure require msvcp110.dll (but I dont' want to delete and test this theory, lol).


Addition details that I have just explored:

   -Changing the Install Location, thinking it was a permissions 

   -Adding the dll file to the Core source directory where the error is not an Explorer.exe application , but an ActivationUI.exe error box (Where the msvcp100.dll is located but the 110 is not) but to no avail.. nothing. Still receiving error.



So silly me, since I have a 64-bit Machine, I was only supposed to install the (x64 redistributable). :smileyhappy:


Posts: 2
Registered: ‎01-12-2014

Re: [SOLVED] Error: Missing MSVCP110.dll Code: 0xC1 [SOLVED]


Did you receive answer to fix this issue ?


It seem tha EA are not very good at helping user fix their issue..

Posts: 1
Registered: ‎02-16-2014

Re: [SOLVED] Error: Missing MSVCP110.dll Code: 0xC1 [SOLVED]

Right Click NFS Rivals > Game Properties > Run as x86.