Help us improve Answer HQ! Take Survey No, Thanks
Ask. Answer. Be the Hero.
Showing results for 
Search instead for 
Do you mean 
Reply
Keeper
fusedslayar
Posts: 1
Registered: ‎06-03-2013

Mass Effect 3 won't connect to EA servers and it's stuck on "Checking DLC"

[ Edited ]

Hello. Read the title for my problem. Earlier today, I played a round or two of MP with my friends on my Xbox. I left to do some things and came back around 2 hours later. Now when I start the game it tells me it's checking my DLC, then my save data, and then my DLC again.
Problem is, it stays on the Checking DLC screen forever. It doesn't freeze, but it just sits there loading. I let it run for about 45 minutes and it was still loading.
It has the little press Y to connect to EA button in the background, and when I hit it it tells me the server is unavaliable and to try again later. I know the servers are up and fine; my friends are all playing right now.
I've tried deleting all the DLC, clearing my cache, disconnecting from the internet and trying then to change my settings only to find that it gets stuck on the Checking DLC pop up even offline, changing discs, and playing it on a different xbox on the same account. Nothing worked. It's driving me crazy right now, for the love of god someone help.

Also, nice live chat, EA. I've been waiting over an hour. ETA 10 minutes, pffffft.