Help us improve Answer HQ! Take Survey No, Thanks
Ask. Answer. Be the Hero.
Showing results for 
Search instead for 
Do you mean 
Reply
Keeper
thespartanburger
Posts: 1
Registered: ‎12-12-2012

Failed to Initialize PhysX Hardware Acceleration

[ Edited ]

This morning, when trying to launch ME3, I would get the following error:

 

"Failed to Initialize PhysX Hardware Acceleration

 

Using hardware accelerated PhysX has been requested, but the driverse were out of date.

 

Please download the latest drivers from

http://www.nvidia.com/object/physx_system_software.html

 

FATAL ERROR - EXITING"

 

At first I was a little confused on this as I have both an AMD CPU and GPU (Phenom II x4 910 and HD6870) and shouldn't even have PhysX installed but doing a little research into the issue, it seems that, because ME3 is an unreal engine game and the unreal engine requires PhysX for some of their visual effects, it is required regardless of what brand card you have.

 

I also found out that others have been having this problem too, however none of their solutions seem to work.

 

First attempt: Repair install ME3. No change.

 

Second attempt: Find the PhysX installer in the ME3 folder, reinstall, and try again. Doing this had no change.

 

Thrid attempt: Download installer and try that. The drivers linked were the 9.12.0213 drivers. No change either.

 

Fourth attempt: Restart your computer. No difference here either.

 

Fifth attempt: Using an alternate link to the drivers, I downloaded the 9.12.1031 drivers and tried those. This time, I get another error while installing. "There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor." Re-downloading the installer yeilded the same result.

 

Sixth attempt: Re-install AMD drivers and Catalyst up to 9.002-120928m-149042C-ATI and 12.10 respectively (2D driver of 8.01.01.1266, Direct3D version 9.14.10.0926, OpenGL version 6.14.10.11931 and VISION version 2012.0928.1532.26058). No change.

 

Seventh attempt: I've seen reports that ME2 had a similar problem, so I decided to launch ME2 to see how well that went (My ME2 copy is digital from steam. My ME3 copy is a physical edition that is now tied to my Origin account). ME2, interestingly, went through PhysX setup and launched just fine. Trying ME3 directly afterwards resulted in the same error as before.

 

  Edit: Eighth attempt: Find the PhysX drivers on the disk (disk 2) and install them (9.11.1107). Unfortunately, because it's within a .zip on the disk and is only openable by the installer, and seeing as how this is just the exact same thing as attempt #2, this had no results.

 

Right then. That's what I've tried with none of those working. I'm going to check the disk for Nvidia drivers and, if that doesn't work, completely uninstall ME3 and reinstall to see if that works.

 

Uninstalling and then reinstalling ME3 fixed the issue. 

Sentinel
zomhead
Posts: 20
Registered: ‎08-21-2012

Re: Failed to Initialize PhysX Hardware Acceleration

Just got this problem today.

 

ME3 MP always stuck on the loading screen.

 

Redownloaded and reinstalled Nvidia drivers, no go.

 

So, going for a whole new ME3 download and install.

Keeper
MovingTarget78
Posts: 1
Registered: ‎05-29-2014

Re: Failed to Initialize PhysX Hardware Acceleration (NecroPost)

[ Edited ]

When ME3 is installed on your machine, the installation includes an "Installer" folder, open this, the subsequent "PhysX" folder, the subsequent "redist" folder: PhysX-(Version)-SystemSoftware.msi will fix your problem in a jiffy

Keeper
CroGamer002
Posts: 1
Registered: ‎07-17-2013

Re: Failed to Initialize PhysX Hardware Acceleration

I'm having this issue right now.

 

I tried most steps, even unistalling and reinstallnig the game.

 

It didn't help.

 

 

What I couldn't do is to install PhysX installer in the ME3 folder nor from Nvidia offical site, as installer keeps telling me I have never version and aborts instalation.

Fred_vdp
Posts: 2,176
Topics: 20
XP: 467
Solutions: 221
Registered: ‎10-04-2012

Re: Failed to Initialize PhysX Hardware Acceleration


CroGamer002 wrote:

What I couldn't do is to install PhysX installer in the ME3 folder nor from Nvidia offical site, as installer keeps telling me I have never version and aborts instalation.


Remove Physx from your PC. It will no longer say you already have a newer version.