Help us improve Answers HQ! Take Survey No, Thanks

Mass Effect on Windows 8

by kirkonacid
Reply

Original Post

Accepted Solution

Mass Effect on Windows 8

★★★★ Novice

I have Mass Effect on Steam and since doing a fresh install of Windows 8, I'm unable to play it. I have tried comepletely disabling UAC and restarting my computer. I select "play," my computers is busy for a moment, and then absolutely nothing happens.

Message 1 of 24 (46,353 Views)

Re: Mass Effect on Windows 8

★★★★ Novice

I had my copy ME 1 from Origin, buy it some days ago. And don't have any problems, game run smooth and fine. Try to re-register your code in Origin client.

Message 2 of 24 (46,145 Views)

Re: Mass Effect on Windows 8

★★★★ Novice

Origin helped, but I also had to run it in compatibility mode (SP3).

Message 3 of 24 (46,139 Views)

Re: Mass Effect on Windows 8

★★★★ Newbie

Thanks for your help, I did the following. I ran Steam\SteamApps\common\Mass Effect\Binaries\MassEffect.exe once in the Windows XP SP3 compatibility mode, then disabled it. It now runs perfect.

Message 4 of 24 (45,992 Views)

Re: Mass Effect on Windows 8

★★★ Newbie

can you help me do that?

Message 5 of 24 (45,737 Views)

Re: Mass Effect on Windows 8

★★★ Newbie

I'm still havin this problem

Message 6 of 24 (39,361 Views)

Re: Mass Effect on Windows 8

★★★★ Novice

how to do run it on compatibility mode??

Message 7 of 24 (39,120 Views)

Re: Mass Effect on Windows 8

[ Edited ]

@dwu03; 

 

You asked

"how to do run it on compatibility mode??"

 

Answer

 

1.  Create a desktop shortcut to the game launcher ("\<user's game program path>\MassEffectLauncher.exe")

 

2.  Right-click on it and choose "Properties" at the bottom.

 

3.  Click the "Compatibility" tab at the top.  (You can actually do steps 2-3 during step 1.)

 

4.  Check the "Compatibility Mode"' box and select "WinXP (SP3) from the drop-down.  (NOTE:  For this kind of thing, I click the "Change for all users" first so that the change will work for everybody on my machine, even though no one else uses it regularly.)

 

5.  Start the game from the shortcut instead of from the EA/Origin client.

 

(While one can apply the "Compatibility Mode" setting directly to the program file, I found that ME1 still wouldn't launch from my EA/Origin client.)

 

Found that I had to set the EA/Origin client to "Run a Administrator" to be able to launch the game when clicking "Play" from within "My Games".

 

That's it! Confusedmileywink:

 

Oh, and of course, one needs to apply the 1.02 patch in order to run the game on Win7 or Win8!

See this topic: [Information] Mass Effect 1 and Windows 7 - You need patch 1.02 to play, which is pinned to the top of this forum

--Thandal
===============================================
If a post solved your problem, click the "Accept as Solution" button.
If you want to answer someone's question, click the "Reply" button.
If you appreciated someone's post, click the "XP" button.

I'm a volunteer, not an EA employee, so I can't get you any deals.
And remember: It's just a game. So play nice.
===============================================
Message 8 of 24 (39,078 Views)

Re: Mass Effect on Windows 8

★★★★ Novice

At least on my computer, there is no compatibility tab visible for masseffect.exe. Has anyone found a way to get around this?

 

Message 9 of 24 (38,044 Views)

Re: Mass Effect on Windows 8

★★★★ Novice

kingofcerealg wrote:

At least on my computer, there is no compatibility tab visible for masseffect.exe. Has anyone found a way to get around this?

 


Yeah the masseffect.exe seems to have no tab for it, change it for the masseffectlauncher.exe, mine starts now after deactivating onboard Graphics.

Message 10 of 24 (37,989 Views)

Accepted Solution

@dwu03; 

 

You asked

"how to do run it on compatibility mode??"

 

Answer

 

1.  Create a desktop shortcut to the game launcher ("\<user's game program path>\MassEffectLauncher.exe")

 

2.  Right-click on it and choose "Properties" at the bottom.

 

3.  Click the "Compatibility" tab at the top.  (You can actually do steps 2-3 during step 1.)

 

4.  Check the "Compatibility Mode"' box and select "WinXP (SP3) from the drop-down.  (NOTE:  For this kind of thing, I click the "Change for all users" first so that the change will work for everybody on my machine, even though no one else uses it regularly.)

 

5.  Start the game from the shortcut instead of from the EA/Origin client.

 

(While one can apply the "Compatibility Mode" setting directly to the program file, I found that ME1 still wouldn't launch from my EA/Origin client.)

 

Found that I had to set the EA/Origin client to "Run a Administrator" to be able to launch the game when clicking "Play" from within "My Games".

 

That's it! Confusedmileywink:

 

Oh, and of course, one needs to apply the 1.02 patch in order to run the game on Win7 or Win8!

See this topic: [Information] Mass Effect 1 and Windows 7 - You need patch 1.02 to play, which is pinned to the top of this forum


Keep your account safe

We'll make sure it's you by sending you a code for your trusted devices.

Learn more about Login Verification on EA Help

Check out the new EA Help!

We want to make finding the help you need better, faster, and easier.

So, we’ve had some work done at help.ea.com