Help us improve Answer HQ! Take Survey No, Thanks
Ask. Answer. Be the Hero.
Showing results for 
Search instead for 
Do you mean 
Reply
Sentinel
c2aye
Posts: 4
Registered: ‎11-12-2013
Accepted Solution

Mass Effect PC (Steam) - General Protection Fault

I have the Steam version of Mass Effect which I have played through once already without any issues. However, recently I have been getting the dreaded general protection fault popping up during dialogue. Before I continue, here are my PC specs:

 

AMD Phenom II X6 1090T 3.20GHz

MSI Geforce GTX 760 2GB (Latest drivers)

8GB RAM

M-Audio Fast Track Audio Interface (External soundcard for recording)

Windows 7 Home Premium SP1 - 64bit

 

My GPU is overclocked but nothing online I've read so far suggests that may be the cause of the issue. I've also run the game in compatibility mode and as an administrater but still no dice.

 

Like I said, I purchased the game through Steam and I've already completed on playthrough (although I should mention that this was on my old GPU, an Nvidia GTS 450). I suspected the issue lay with an HD texture mod (link: http://www.moddb.com/mods/mass-effect-1-new-texture-updatesimprovements-mod) but after verifying the game cache, returning the game to its pre-modded state, I still get the bug. It always occurs during dialogue. At the moment, I am at the point in the game after recruiting Liara on Therum and conversations with various crew members leads to the bug. It had occured a various points beforehand as well.

 

I checked the specific bug details and this is what Windows had to say:

 

Faulting application name: MassEffect.exe, version: 1.2.20608.0, time stamp: 0x4a55fea1
Faulting module name: wrap_oal.dll_unloaded, version: 0.0.0.0, time stamp: 0x46927487
Exception code: 0xc0000005
Fault offset: 0x09f5f9e0
Faulting process id: 0x1d58
Faulting application start time: 0x01cedf4cd4921535
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\Mass Effect\Binaries\MassEffect.exe
Faulting module path: wrap_oal.dll
Report Id: 0f2f84f7-4b41-11e3-b504-f46d0439bfcb

 

wrap_oal.dll is something to do with audio as far as I am aware but I'm not 100% sure. I've read that there are issues with hardware/software audio before but again, I'm not sure. I'm using an M-Audio Fast-Track audio interface as an external soundcard as I also use my computer for recording but I have no idea whether that will have an effect or not.

 

Any help or suggestions would be appreciated. Apart from the bug, the game runs very well and looks much improved with that texture mod.

Fred_vdp
Posts: 1,966
Topics: 17
XP: 440
Solutions: 205
Registered: ‎10-04-2012

Re: Mass Effect PC (Steam) - General Protection Fault

[ Edited ]

First of all, make sure the game is patched to the last version. If that's already the case, read on.

 

This error can be caused by bad drivers. Nvidia has horrible support for Mass Effect and older games in general, so you may have to roll back to an older driver version.

 

Having said that, there's one sidemission in particular that can trigger the GPF error even if your drivers are compatible. It's a mission on the Citadel where an NPC asks you to bring him some drugs from Dr. Michel's office. If that mission is active, the game can crash from time to time until it's completed.

Sentinel
c2aye
Posts: 4
Registered: ‎11-12-2013

Re: Mass Effect PC (Steam) - General Protection Fault

[ Edited ]

Thanks for your reply. My version of Mass Effect is 1.02 as it is automatically updated through Steam.

 

I'm reluctant to roll back my drivers as I would rather not lose support for a lot of more recent games (Mass Effect 3 included) so I'm leaving this as an absolute last resort. I appreciate that while this may be the cause, I've not had issues with any other games released around 2007 or other games that use the Unreal engine.

 

As I said, the initial crash was caused by wrap_oal.dll which is something to do with audio, so I tried the following fix http://social.bioware.com/forum/1/topic/106/index/656205/2

 

"1) in /program files/Mass Effect/Binaries locate the OpenAL32.dll and wrap_oal.dll files

2) Rename OpenAL32.dll to OpenAL32.bak

3) Rename wrap_oal.dll to OpenAL32.dll

4) Launch as Admin by using the MassEffect.exe"

 

However, I got another general protection fault error, this time reading as such;

 

Faulting application name: MassEffect.exe, version: 1.2.20608.0, time stamp: 0x4a55fea1
Faulting module name: KERNELBASE.dll, version: 6.1.7601.18229, time stamp: 0x51fb1116
Exception code: 0x40010006
Fault offset: 0x0000c41f
Faulting process id: 0x3e4c
Faulting application start time: 0x01cee01460f2b6cc
Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\Mass Effect\Binaries\MassEffect.exe
Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
Report Id: deae1d03-4c07-11e3-a6c1-f46d0439bfcb

 

This time, the faulting module was kernelbase.dll which as far as I am aware is something to do with running 32-bit programs within a 64-bit operating system so this time I assumed the fault lay with compatibility. I ran Steam as an administrater and ran Mass Effect in Windows XP SP2 compatibility mode (I read somewhere to use SP2 specifically but I'm not sure what difference that would make). So far, I've gotten through all the crew dialogue on the Normandy where the crashes originally occurred and played about an hour of the game without any crashes. I'm very reluctant to say that the issue is solved so I'll keep a look out while playing further.

 

Hero
max_exter
Posts: 385
Registered: ‎08-21-2013

Re: Mass Effect PC (Steam) - General Protection Fault

I was all set to send you the same link you refered to in your response.  My children make me slow, apparently.  

 

How has it gone?  If you get to some point where it looks like things are going to keep working (maybe even beating the game) do come back and mark your second message as the solution.  

Sentinel
c2aye
Posts: 4
Registered: ‎11-12-2013

Re: Mass Effect PC (Steam) - General Protection Fault

Like I said, the first fix worked for a while until that compatibility issue came up. Apparently ME1 doesn't like running on 64-bit operating systems (or my one, at the very least!).

 

I've managed another couple of hours of playthrough with no issue so I think the above sorted the issue. Also, do check out the mod I posted in the first link, really brings out the best in the game (and fixes the awful vanilla film grain and Garrus's face texture!). Running in XP compatibility mode does mean I can no longer monitor my framerate using MSI Afterburner but I guess I was getting 100-150 frames per second most of the time so that isn't that big of an issue.

 

I guess I would add that my advice for anybody suffering from the general protection fault is to click start, search for 'reliability' and open 'view reliability history'. Isolate the source of the problem and go from there.

Keeper
dangerstepp
Posts: 1
Registered: ‎11-18-2013

Re: Mass Effect PC (Steam) - General Protection Fault

I am having the same issue as everyone else and I am absolutely perplexed that a solid solution has not been provided.

 

While I am not experiencing any GPFs that prevent me from progressing, they occur often enough to warrant me Googling for a solution every other time it happens.

 

I will try the solutions as suggested above to see if I have better luck.

 

I'm running ATI HD 7950 (although older forum threads from Bioware users swear this is endemic of Nvidia cards only...wrong!) @ 5276x1050 resolution.  I'm also using the updated Mass Effect textures pack, which judging by the number of threads created by the this problem, have nothing to do with it.

 

I see the span of time this has been an issue and no one has a clear answer and it floors me.

Sentinel
c2aye
Posts: 4
Registered: ‎11-12-2013

Re: Mass Effect PC (Steam) - General Protection Fault

The issue lies around the fact that there is no one cause of the problem. I myself had the problem turn up due to two completely unrelated things. I think we just have to accept that Bioware are far too busy messing around with Frostbite 3 to come back to try and sort this out.

 

Like I said above, view your reliability and isolate the source of the error (ie, the faulting module). Hopefully that will give you some clue as to what caused your iteration of the GPF.