Help us improve Answers HQ! Take Survey No, Thanks

This application is not compatible with the installed operating system. Please upgrade to Windows 98SE, Windows 2000 or better.

by steelmachinist
Reply

Original Post

This application is not compatible with the installed operating system. Please upgrade to Windows 98SE, Windows 2000 or better.

★★★★ Newbie

I tried launching Crysis 1, but this error pops up whenever I do: "This application is not compatible with the installed operating system.
Please upgrade to Windows 98SE, Windows 2000 or better."

 

I have Windows 8 Professional, Intel i7-3770K, 8GB RAM, nVidia GTX 680. I bought Crysis in Amazon. All was running fine until yesterday.

 

If this is a SecuROM issue,

Spoiler
then you are a POS company EA. I pirated Crysis in 2009, but now I have a McJob, I decided buying games is the right thing to do. No, I think we were right all along. We should not support POS companies like EA and never buy any product they make. Instead let us patronize their competition instead.

 

 

Message 1 of 1 (1,356 Views)
Reply
0

Secure your account

Turn on Login Verification to protect your information.

View more on EA Help