Help us improve Answers HQ! Take Survey No, Thanks

Crysis (original) and Windows 8

by ogre840

Original Post

Re: Crysis (original) and Windows 8

★★★★ Newbie

I have windows 8 installed and Crysis worked for a while until I got this error message. Uninstalling and reinstalling graphics drivers then installing crysis again worked for me.

Message 11 of 35 (11,295 Views)

Re: Crysis (original) and Windows 8

★★★★ Novice

Same me, I hate EA

Message 12 of 35 (11,194 Views)

Re: Crysis (original) and Windows 8

[ Edited ]
★★★★ Newbie

Crysis wont start on Win8 Pro 64bit. No matter how I try to open it the game crashes about 5 seconds in after black screen appears ("The program has stopped working"). I've completely updated my hardware drivers as well as crysis and I've tried all the compatibility options as well as through administrator.




Antec Nine Hundred


Intel Core i7-920 2.66 GHz

BFG GeForce GTX 285 OC2 1024 x2 SLI

OCZ DDR3 PC3-10666 / 1333MHz Gold Edition 12GB (6x2GB)


Thermaltake Black Widow V1

2x 300GB HDD 7200RPM RAID 0


Message 13 of 35 (11,174 Views)

Re: Crysis (original) and Windows 8

★★★★★ Newbie

Golly gee, thanks for giving me the original Crysis with my Crysis 3 pre-order...  too bad I can't even play it.

(Windows 8)

Message 14 of 35 (10,792 Views)

Re: Crysis (original) and Windows 8

★★★★ Newbie

I cant open this game either and this sucks throwing away money down the toilet to EAConfusedmileyembarrassed:

Message 15 of 35 (10,782 Views)

Re: Crysis (original) and Windows 8

★★★ Newbie


Same exact situation. I really don't know what to do I since everything doesn't really fix the problem. I got it as apart of the preorder for Crysis 3 and it just won't start up. Really frustrating seeing as I want to play this one before I jump into the second or third.

Message 16 of 35 (10,721 Views)

Re: Crysis (original) and Windows 8

★★★★ Novice

Ok guys I got mine to work on windows 8.. First I uninstalled the whole **bleep** game delete the folder of crysis and went to users/documents/mygames and delete any thing there too.. now make you make steam not start with windows and turn off avg or uninstall.. now download and reinstall crysis start game! This is what I did and my game is now working.. I hope this works for you guys too Standard smile

Message 17 of 35 (10,677 Views)

Re: Crysis (original) and Windows 8

★★★★ Novice
I asked EA customer support about this, after buying a retail disc last week and not being able to run in on Windows 8. Three days later their 'official' reply was to refer me to this topic, which is no help whatsoever. In the meantime, though, I found my own solution. I downloaded something called Crysis 64-bit no-cd crack, from a torrent site, and sure enough the game works perfectly with it. So there's a 100% working patch available, just not from the game's publisher / developer.
Message 18 of 35 (10,470 Views)

Re: Crysis (original) and Windows 8

★★★★ Novice

I have just installed Crysis for the first time in a few years and its not working for me either, the funny thing is after I installed it

I could play for a few hours. It wasn't until I restarted my computer and tried playing again it happened.


They need to release a patch pronto, I cant believe they are giving Crysis away free with Crysis 3 when it doesn't work on Win 8.

Message 19 of 35 (10,431 Views)

Re: Crysis (original) and Windows 8

★★★★ Novice

I had this stop working for me all of a sudden on Windows 8 64 bit after it being ok since I originallly bought. I tried compatibility, uninstalling, the 64 bit hack, nothing.


Then today I tried removing securom, I was prompted for my login details again to activate but now it works, maybe it will work for one of you.

Message 20 of 35 (10,372 Views)

Accepted Solution

★★★★ Novice

I was able to run Crysis on Windows 8, 64 bits, through Origin by doing this:


  • Inside Origin, select "Origin > Add Game..."
  • Enter the location to the 32 bits executable of Crysis (for example: C:\Program Files (x86)\Electronic Arts\Crytek\Crysis\Bin32\Crysis.exe)
  • Now right-click on the newly added Origin shortcut and select "Shortcut Properties..."
  • In the Command Line Arguments, type: -dx9
  • Click "OK" to accept

With this, I got a working shortcut to Crysis. It works for me. It might not work for you. If you try this, let people know here if it works for you or not.

Keep your account safe

We'll make sure it's you by sending you a code for your trusted devices.

Learn more about Login Verification on EA Help

Check out the new EA Help!

We want to make finding the help you need better, faster, and easier.

So, we’ve had some work done at