Help us improve Answer HQ! Take Survey No, Thanks
Ask. Answer. Be the Hero.
Showing results for 
Search instead for 
Do you mean 
Reply
Keeper
dertuw
Posts: 1
Registered: ‎01-29-2013
Accepted Solution

You need a DX11 capable GPU to play Crysis 3 MP Open Beta

Hello. Faced with such a problem: when start Crysis 3 Mp Open Beta  generates this error - You need a DX11 capable GPU to play Crysis 3 MP Open Beta.

But I have DX11. Dxdiag file:

 

Machine name: DERTUW13
Operating System: Windows 7 Максимальная 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_rtm.101119-1850)
Language: Russian (Regional Setting: Russian)
System Manufacturer: MICRO-STAR INTERANTIONAL CO.,LTD
System Model: MS-7367
BIOS: Default System BIOS
Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 5600+ (2 CPUs), ~2.8GHz
Memory: 2048MB RAM
Available OS Memory: 2048MB RAM
Page File: 2446MB used, 3206MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11

 

Please help to understand the reason

Keeper
emrecan22
Posts: 8
Registered: ‎01-06-2013

Re: You need a DX11 capable GPU to play Crysis 3 MP Open Beta

Cryet has to fix it i mean why we cant play with directx 10/9  !!!1

Keeper
rifezjke
Posts: 2
Registered: ‎01-29-2013

Re: You need a DX11 capable GPU to play Crysis 3 MP Open Beta

I has problem like you have, also cfg of my PC like your. So, i play BF3, it mean i have DX11 and dxdiag show me, that i have DX11. i hope crytek fix it soon

Keeper
sheva2471
Posts: 8
Registered: ‎11-30-2012

Re: You need a DX11 capable GPU to play Crysis 3 MP Open Beta

get a new graphic card, directx 10/9 are getting old....

Keeper
rifezjke
Posts: 2
Registered: ‎01-29-2013

Re: You need a DX11 capable GPU to play Crysis 3 MP Open Beta

He has a DX11 capable videocard, in this all problem

Keeper
thedronik
Posts: 1
Registered: ‎01-29-2013

Re: You need a DX11 capable GPU to play Crysis 3 MP Open Beta

[ Edited ]

dertuw wrote:

Hello. Faced with such a problem: when start Crysis 3 Mp Open Beta  generates this error - You need a DX11 capable GPU to play Crysis 3 MP Open Beta.

But I have DX11. Dxdiag file:

 

Machine name: DERTUW13
Operating System: Windows 7 Максимальная 64-bit (6.1, Build 7601) Service Pack 1 (7601.win7sp1_rtm.101119-1850)
Language: Russian (Regional Setting: Russian)
System Manufacturer: MICRO-STAR INTERANTIONAL CO.,LTD
System Model: MS-7367
BIOS: Default System BIOS
Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 5600+ (2 CPUs), ~2.8GHz
Memory: 2048MB RAM
Available OS Memory: 2048MB RAM
Page File: 2446MB used, 3206MB available
Windows Dir: C:\Windows
DirectX Version: DirectX 11

 

Please help to understand the reason

 

EA_Dennis
Posts: 7,501
Topics: 190
XP: 2,020
Solutions: 2,938
Registered: ‎09-22-2012

Re: You need a DX11 capable GPU to play Crysis 3 MP Open Beta

Hi, 

Unfortunately, you have only posted the first part of your DxDiag report, so we don't know what graphics card you are using. Please post the full report or just let us know what graphics card you are using.

The line you are quoting from the DxDiag report only states that DirectX 11 is installed on your computer and that Windows 7 is capable of using it. However, if your graphics card is not capable of DirectX 11, you can't run the game.

 

You can find a list of all the Nvidia and AMD graphics card and what version of DirectX they are capable of here:

http://en.wikipedia.org/wiki/Comparison_of_Nvidia_graphics_processing_units

http://en.wikipedia.org/wiki/Comparison_of_AMD_graphics_processing_units

Keeper
phileee
Posts: 8
Registered: ‎01-29-2013

Re: You need a DX11 capable GPU to play Crysis 3 MP Open Beta

Same problem here with a Radeon HD 5850 (which is a DirectX11 GPU). Newest drivers are installed as well... :smileyfrustrated:

Keeper
ev3ns
Posts: 1
Registered: ‎01-29-2013

Re: You need a DX11 capable GPU to play Crysis 3 MP Open Beta

same problem, i got GT520MX ( support DX11 ), but cant play C3 :smileysad:

Keeper
lahidtr
Posts: 8
Registered: ‎01-29-2013

Re: You need a DX11 capable GPU to play Crysis 3 MP Open Beta

mr.

 

Directx       opengl

  11.0           4.2

 

I wonder what is the solution to this question, Mr. admin?