Help us improve Answer HQ! Take Survey No, Thanks
Ask. Answer. Be the Hero.
Showing results for 
Search instead for 
Do you mean 
Reply
Sentinel
richardwilcox
Posts: 3
Registered: ‎04-09-2013
Accepted Solution

Battlefield Bad Company 2 - Blue Screen of Death.

Hello,

 

Thank you for reading this.

 

My computer is new. I built it less than 6months ago. It has been running fine for that time without any issue whatsoever. Today I started getting BSOD's when I run BF:BC2. When I boot the game the core temperature of my PC rises and doesn't stop, eventually (I believe) causing the BSOD. This does not happen on any other games. I run everything at maximum and regularly play multiple games at once. I have taken my PC to bits and cooled it with extra fans - this only makes it take longer to do it.

 

BSOD Info :

 

Problem signature:
  Problem Event Name:    BlueScreen
  OS Version:    6.1.7601.2.1.0.768.3
  Locale ID:    2057

Additional information about the problem:
  BCCode:    124
  BCP1:    0000000000000000
  BCP2:    FFFFFA8006FA4028
  BCP3:    00000000BF800000
  BCP4:    0000000000200001
  OS Version:    6_1_7601
  Service Pack:    1_0
  Product:    768_1
 

Minidump Info (Retrieved using Windbg)

 

Microsoft ® Windows Debugger Version 6.2.9200.20512 AMD64
Copyright © Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Windows\Minidump\040913-9079-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*E:\Symbols*http://msdl.microsoft.com/download/symbols
Executable search path is:
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7601.18044.amd64fre.win7sp1_gdr.130104-1431
Machine Name:
Kernel base = 0xfffff800`02e65000 PsLoadedModuleList = 0xfffff800`030a9670
Debug session time: Tue Apr  9 13:14:53.053 2013 (UTC + 1:00)
System Uptime: 0 days 0:34:26.380
Loading Kernel Symbols
...............................................................
................................................................
........................
Loading User Symbols
Loading unloaded module list
.....
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 124, {0, fffffa8006fa4028, bf800000, 200001}

Probably caused by : GenuineIntel

Followup: MachineOwner
---------

2: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

WHEA_UNCORRECTABLE_ERROR (124)
A fatal hardware error has occurred. Parameter 1 identifies the type of error
source that reported the error. Parameter 2 holds the address of the
WHEA_ERROR_RECORD structure that describes the error conditon.
Arguments:
Arg1: 0000000000000000, Machine Check Exception
Arg2: fffffa8006fa4028, Address of the WHEA_ERROR_RECORD structure.
Arg3: 00000000bf800000, High order 32-bits of the MCi_STATUS value.
Arg4: 0000000000200001, Low order 32-bits of the MCi_STATUS value.

Debugging Details:
------------------


BUGCHECK_STR:  0x124_GenuineIntel

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  WIN7_DRIVER_FAULT

PROCESS_NAME:  PnkBstrB.exe

CURRENT_IRQL:  f

STACK_TEXT:  
fffff880`02f6da58 fffff800`02e2ea3b : 00000000`00000124 00000000`00000000 fffffa80`06fa4028 00000000`bf800000 : nt!KeBugCheckEx
fffff880`02f6da60 fffff800`02ff1633 : 00000000`00000001 fffffa80`06ed1b70 00000000`00000000 fffffa80`06ed1bc0 : hal!HalBugCheckSystem+0x1e3
fffff880`02f6daa0 fffff800`02e2e700 : 00000000`00000728 fffffa80`06ed1b70 fffff880`02f6de30 fffff880`02f6de00 : nt!WheaReportHwError+0x263
fffff880`02f6db00 fffff800`02e2e052 : fffffa80`06ed1b70 fffff880`02f6de30 fffffa80`06ed1b70 00000000`00000000 : hal!HalpMcaReportError+0x4c
fffff880`02f6dc50 fffff800`02e2df0d : 00000000`00000004 00000000`00000001 fffff880`02f6deb0 00000000`00000000 : hal!HalpMceHandler+0x9e
fffff880`02f6dc90 fffff800`02e21e88 : 00000000`00000002 00000000`00001000 00000000`00000000 00000000`00000000 : hal!HalpMceHandlerWithRendezvous+0x55
fffff880`02f6dcc0 fffff800`02ed952c : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : hal!HalHandleMcheck+0x40
fffff880`02f6dcf0 fffff800`02ed9393 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxMcheckAbort+0x6c
fffff880`02f6de30 fffff800`02ed16e4 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiMcheckAbort+0x153
fffff880`03de7638 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!memmove+0xb4


STACK_COMMAND:  kb

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: GenuineIntel

IMAGE_NAME:  GenuineIntel

DEBUG_FLR_IMAGE_TIMESTAMP:  0

FAILURE_BUCKET_ID:  X64_0x124_GenuineIntel_PROCESSOR_MAE

BUCKET_ID:  X64_0x124_GenuineIntel_PROCESSOR_MAE

Followup: MachineOwner
---------

I have attached a dxdiag file just because I could.

 

Please note :

 

I have read around this topic already.

AVG and Malwarebytes are currently in progress.

I do not have a CD burner so I cannot burn Memtest86 to a cd and boot from it. I do have memory sticks if someone can tell me if that works and how.

I do have my windows 7 disc, so I can do repairs. Please inform me if doing this will format anything as backing up is a big deal for me.

 

I appreciate any/all help or advice. Thank you everyone.

 

Edit:

 

I do not overclock anything

I do not use MSI afterburner

I have sufficient cooling

I have turned off all programs that could conflict with it (even firewalls etc)

Sentinel
richardwilcox
Posts: 3
Registered: ‎04-09-2013

Re: Battlefield Bad Company 2 - Blue Screen of Death.

I still need support on this issue EA.

Sentinel
andreyoung
Posts: 10
Registered: ‎04-09-2013

Re: Battlefield Bad Company 2 - Blue Screen of Death.

[ Edited ]

You see:

DEFAULT_BUCKET_ID:  WIN7_DRIVER_FAULT

PROCESS_NAME:  PnkBstrB.exe

 

Try update PunkBuster. Uninstall from windows and install from this link http://www.evenbalance.com/downloads/pbsvc/pbsvc.exe , then download PBSetup 3.5 from http://www.evenbalance.com/index.php?page=pbsetup.php and update PunkBuster files in game folder.

 

And how specifications have your PC?

 

 

 

 

Sentinel
richardwilcox
Posts: 3
Registered: ‎04-09-2013

Re: Battlefield Bad Company 2 - Blue Screen of Death.

Punkbuster was updated.

 

For anyone else looking for a solution to this :

 

Disabling EasyTune6 (And any other overclocking software) and disabling any kind of monitoring software (GPUZ, CPUZ) fixed this for me. Punkbuster is a piece of junk which was causing my CPU to fail if I had these other programs open.

 

This fix has been confirmed on two different machines.