Help us improve Answer HQ! Take Survey No, Thanks
Ask. Answer. Be the Hero.
Showing results for 
Search instead for 
Do you mean 
Reply
Keeper
jimmyt1988
Posts: 8
Registered: ‎09-26-2013

Battlefield 4 Plugin for IE11 not working

  • I am using IE11. (on windows 8.1 - stable release etc)
  • I get to the server browser and pick a server to join, when i start to join it says i need the latest plugin.
  • I hit run, it downloads the file then runs it.
  • It then opens up a desktop application that installs something.
  • Nothing happens to say it is finished apart from the application just closing on completion.
  • I hit the continue button... I try to rejoin.
  • It says it needs the browser plugin.

I CAN'T PLAY BF4 Multiplayer... :'( !!!!

Keeper
jimmyt1988
Posts: 8
Registered: ‎09-26-2013

Re: Battlefield 4 Plugin for IE11 not working

ADD the battlelog site to your trusted sites (untick the bottom tick) when adding it.. otherwise it says you cant add because its not https.

Keeper
jaguarjoey
Posts: 3
Registered: ‎11-02-2013

Re: Battlefield 4 Plugin for IE11 not working

[ Edited ]

I am having the same issue as well. 

 

My rig:

 

Intel Core i7 950 @3.07GHz

24 GB Ram

GeForce GTX 680

Win 8.1 Pro (Stable release)  w/ IE 11

 

I have found some other posts that state installing Chrome and running the game from there is a workaround.   However, I consider this only a band-aid fix to get me into the game.  I'm one of those rare individuals that prefers to use Internet Explorer and I'm not happy that I need to install Chrome for a game I paid $70 for.  If they say it's Windows 8 compatible (and "Recommended"), then they should have obviously tested with IE 11. 

 

I'm about to test the last post regarding adding battlelog.com to the trusted sites-- that should work... so thanks for the tip!

 

--JaguarJoey

Keeper
jaguarjoey
Posts: 3
Registered: ‎11-02-2013

Re: Battlefield 4 Plugin for IE11 not working

[ Edited ]

IE 11 works fine when added to the Trusted Sites.

 

If anyone needs to know how to add it to Trusted Sites,  Perform the following steps:

 

  • Launch BF4 and log in.
  • Once you are in the BattleLog Screen, Click on the "Tools" icon (the little gear) towared the top-right of the browser window (or hit ALT-X) and go to "Internet Options"
  • Click on the "Security" Tab
  • Click on the "Trusted Sites" icon
  • Click "Sites"
  • Un-check "Require server verification (https: ) for all sites in the zone
  • In the field "Add this websited to the zone:"  you should have http://battlelog.battlefield.com , if not, type that in.
  • Re-launch the game and you should be good to go!

Enjoy!

 

--JaguarJoey

 

Keeper
jimmyt1988
Posts: 8
Registered: ‎09-26-2013

Re: Battlefield 4 Plugin for IE11 not working

Yea, but i'd prefer a real solution. Dice most likely have to add the site to https as i noticed it currently isn't. At that point it shouldn't need to be added to ttrusted sites. The current solution isn't really acceptible. But thanks for the full instructions to atleast get people going!

Keeper
jimmyt1988
Posts: 8
Registered: ‎09-26-2013

Re: Battlefield 4 Plugin for IE11 not working

This solution actualy does not work. You can no longer visit battlelog.battlefield.com and log in if you have added the site to trusted sites. You can only log in through Origin then. It's terrible, please solve this bug!!!

Keeper
schnitz76
Posts: 1
Registered: ‎11-15-2013

Re: Battlefield 4 Plugin for IE11 not working

I just updated to IE11 through Windows Updates and can no longer get to Battlelog to launch Battlefield 4. If I try the trusted sites trick I can no longer log into the website.
Keeper
jimmyt1988
Posts: 8
Registered: ‎09-26-2013

Re: Battlefield 4 Plugin for IE11 not working

There's no solution to this... and considering no response it seems the web team don't really care at all.. Worst part of it is that developers have a stigma for internet explorer and they just ignore it... without reason, Since IE10 the browser has been a god send... They also forget to realise that chrome and firefox have NO touch support... so for crying out loud, pleaseee sort this issue out for the people who have touch screens... Your web application DOES NOT WORK at this very moment!

 

There is also a performance issue on the web application, when you are scrolling... jquery has some scroll event hooked up for no bloody reason... so when you're scrolling, it's running code (that is synchronous) and slowing down the browser thread. It's really annoyyyying.

 

As to solving your problem for now, you have no other choice but to download either "Firefox" or "Chrome" as IE11 has simply been ignored as a browser.

 

I'm so frustrated at this. Oh by the way mate, don't worry about IE11... You are not alone, and with IE11 being the fastest browser for rendering, processing javascfript, interacting with HTML 5 and canvas rendering, I suggest you stick with it.

 

As a developer myself, i find if i code for internet explorer and then try it out on firefox and chrome, i never end up having issues... if you develop for chrome, alot of the stuff does't work on ie... That's because Chrome sets standards, it doesn't follow them. WebGL for a start... Not a standard, if IE had done that, everyone would say "Oh Microsoft is setting new standards again bla bla bla", but no.. Google with their eyes in your bedroom, grabbing their shrivelled willies looking at you using their browser go and add a new feature and then instantly everyone is like... standardddddddd.

 

Web team are probbably thinking "Noone uses IE11 anyway"... NO, NO... no NO no no no no.. It's coz we can't use it with your bloody web application. WE ARE FORCED to use Dome and FiredPox

Carbonic
Posts: 5,751
Topics: 46
XP: 2,639
Solutions: 1,134
Registered: ‎12-13-2012

Re: Battlefield 4 Plugin for IE11 not working


jimmyt1988 wrote:

There's no solution to this... and considering no response it seems the web team don't really care at all.. Worst part of it is that developers have a stigma for internet explorer and they just ignore it... without reason, Since IE10 the browser has been a god send... They also forget to realise that chrome and firefox have NO touch support... so for crying out loud, pleaseee sort this issue out for the people who have touch screens... Your web application DOES NOT WORK at this very moment!

 

There is also a performance issue on the web application, when you are scrolling... jquery has some scroll event hooked up for no bloody reason... so when you're scrolling, it's running code (that is synchronous) and slowing down the browser thread. It's really annoyyyying.

 

As to solving your problem for now, you have no other choice but to download either "Firefox" or "Chrome" as IE11 has simply been ignored as a browser.

 

I'm so frustrated at this. Oh by the way mate, don't worry about IE11... You are not alone, and with IE11 being the fastest browser for rendering, processing javascfript, interacting with HTML 5 and canvas rendering, I suggest you stick with it.

 

As a developer myself, i find if i code for internet explorer and then try it out on firefox and chrome, i never end up having issues... if you develop for chrome, alot of the stuff does't work on ie... That's because Chrome sets standards, it doesn't follow them. WebGL for a start... Not a standard, if IE had done that, everyone would say "Oh Microsoft is setting new standards again bla bla bla", but no.. Google with their eyes in your bedroom, grabbing their shrivelled willies looking at you using their browser go and add a new feature and then instantly everyone is like... standardddddddd.

 

Web team are probbably thinking "Noone uses IE11 anyway"... NO, NO... no NO no no no no.. It's coz we can't use it with your bloody web application. WE ARE FORCED to use Dome and FiredPox


First of all I agree that it's not acceptable that IE support is there and that there's been no comment on this. I however do not work for EA and can't make a response happen. However if someone provides you with a workable workaround for your technical issue you should accept the solution, accepting does not tell EA that it's no more a problem, but only that the provided solution allows you to play the game. To give feedback about IE11 not working and that it's wrong you should use the feedback forum on Battlelog.

 

IE11 being the fastest I don't agree with. Also, technically Mozilla created WebGL and why shouldn't they be able to create standards as well as Microsoft.

Keeper
nutzdamoose
Posts: 1
Registered: ‎11-16-2013

Re: Battlefield 4 Plugin for IE11 not working

in internet options, make sure the ea extensions are enabled (32 bit). IE11 works ok for me.