Help us improve Answers HQ! Take Survey No, Thanks

Battlefield 4 Beta || Plugin Error

by evolutionQQ
Reply

Original Post

Battlefield 4 Beta || Plugin Error

★★★★ Novice

Download and install the latest Browser Plugin to play the game.

 

again and again this WTF ?!

 

 

ea live chat cant help, running mozzila firefox 24.0, adblock disabled & kaspersky disabled, reinstall & redownload web plugin, ccleaner pc, repair cheack installation of bf4, pc restart.

>> https://help.ea.com/article/battlelog-startup-trouble << triead all of this stuff NOT WORKING

 

 

So how is chance I would be able to play Battlefield 4 at release ?

 

thank you

Message 1 of 10 (8,745 Views)

Re: Battlefield 4 Beta || Plugin Error

★★★★ Novice

Pure Rage i had same Problem too

 

Message 2 of 10 (5,508 Views)

Re: Battlefield 4 Beta || Plugin Error

★★★★ Newbie

I was having the same problem, i disabled adblock for the bf4 webpage and it worked. Give it a try

Message 3 of 10 (5,377 Views)

Re: Battlefield 4 Beta || Plugin Error

★★★★ Newbie

everytime i try play bf4 i install the plugin and went i try play its says bf4 has stopped wroking my head is wrecked and have tried everything and nothing

Message 4 of 10 (3,640 Views)

Re: Battlefield 4 Beta || Plugin Error

[ Edited ]
★★★★ Novice

The problem is the IE security. To resolve it you need to add the battlefield URL to the Trusted Zone on your browser.

 

I'll guess that you are runnning Win8.1 with IE11?

 

1. Click on the gear cog on the top right and select Internet Options.

 

2. Select the Security Tab on the pop-up

 

3. Select the Trusted Sites, green tick

 

4. Click on the Sites button under the green tick

 

5. Untick 'Require server verification...'

 

6. Copy this into the 'Add this site to the zone' dialog:  http://battlelog.battlefield.com/bf4/ and click Add

 

7. Retick the 'Require server verification...' tickbox

 

8. Close the browser and then launch BF4.

 

If I have the wrong browser, come back to me and I'll help out. I'm using IE11 64bit no probs now. All I gotta do now is learn to shoot straight!

 

Message 5 of 10 (3,628 Views)

Re: Battlefield 4 Beta || Plugin Error

★★★★ Novice

adding it as a trusted server wroked for me - thanks!

Message 6 of 10 (2,435 Views)

Re: Battlefield 4 Beta || Plugin Error

★★★★ Newbie

This worked perfectly for me. Thanks a lot

Message 7 of 10 (2,321 Views)

Re: Battlefield 4 Beta || Plugin Error

★★★★ Novice

Im haveing a prob with the web plugin It keeps telling me that I need to install it and I did I think I did and when I go to play on-line I get a message that I need to install the latest web-plugin, It's the plugin that's with the newest patch Nov 14 2013.   

Message 8 of 10 (2,094 Views)

Re: Battlefield 4 Beta || Plugin Error

★★★★ Novice
Message 9 of 10 (2,080 Views)

Re: Battlefield 4 Beta || Plugin Error

★★★★ Novice

problem solved bf4 uninstalled

Message 10 of 10 (2,047 Views)

Keep your account safe

We'll make sure it's you by sending you a code for your trusted devices.

Learn more about Login Verification on EA Help

Check out the new EA Help!

We want to make finding the help you need better, faster, and easier.

So, we’ve had some work done at help.ea.com